HowToMoodle Blog

Moodle 2.8 security fix support ends - plus Moodle's minor releases

Moodle logoIn addition to the release of the latest minor versions today, Moodle 2.8 has now reached the end of it's security fix support. This means that Moodle will no longer provide security fix releases should any future issues arise. Moodle 2.9 is also now supported for security fixes only. If you are on a version that is 2.8 or older it is strongly recommended to upgrade your Moodle version to a later version.

 

Moodle versions - 2.8 security fixes end - 9th May 2016

Moodle HQ have released their latest releases for 3.0.4, 2.9.6, 2.8.12 and 2.7.14. Find out more about each minor release below.

Moodle 2.7.14 and Moodle 2.8.12

  • Security-related issues have now been resolved.

Moodle 2.9.6

  • Assignment activity: Issue has been resolved regarding logging in as another user and changing the field "Last modified (submission)"
  • Database activity: "Save and add another" button will now not pre-populate the form with data from previous entry
  • Atto editor: The issue has been fixed regarding the background color being no longer applied when pasting clipboard content (due to Chrome problems)
  • Database activity: Do not display coding error when searching a database with no entries - this has been fixed
  • Upload users tool now no longer breaks because of the wrong case in user email
  • Performance improvement to grade history report
  • Wikimedia repository: Now able to consistently import any .svg files
  • Database activity: Setting field type Number to required should allow zero value
  • LTI activity: Now able to uninstall ltisource plugins
  • Improvements to file format selector in import/export questions form
  • Security-related issues have now been resolved.

Moodle 3.0.4

  • Assignment activity: Issue has been resolved regarding logging in as another user and changing the field "Last modified (submission)"
  • Performance improvement in backups with logs
  • Database activity: "Save and add another" button will now not pre-populate the form with data from previous entry
  • Atto editor: The issue has been fixed regarding the background color being no longer applied when pasting clipboard content (due to Chrome problems)
  • Database activity: Do not display coding error when searching a database with no entries - this has been fixed
  • Upload users tool now no longer breaks because of the wrong case in user email
  • Permissions of files created during the plugin installation should follow configuration settings
  • Performance improvement to grade history report
  • Wikimedia repository: Now able to consistently import any .svg files
  • Database activity: Setting field type Number to required should allow zero value
  • LTI activity: Now able to uninstall ltisource plugins
  • Improvements to file format selector in import/export questions form
  • Security-related issues have now been resolved.

Need help with upgrading your site? Get in touch with our friendly team on 0330 660 1111 or contact us here.


Share this: