HowToMoodle BlogSubscribe to our Blog

Why should I upgrade my Moodle or Totara Learn site?

by Gemma Mellings on | Apr 18, 2016 | Blog | 0 comments

Blog Image 2 - The 1 Reason To Upgrade NowWith frequent Moodle and Totara Learn major versions being released at least every six months - and minor versions released more regularly - it's understandable that it can be hard to keep up-to-date with version upgrades and whether there is really any benefit in doing so. 

There are, in fact, 4 key reasons why it's important to keep your Moodle or Totara Learn site up-to-date with version releases.

1. Security 

Moodle and Totara version upgrades include patches for potential security vulnerabilities. For both systems the underlying processes for dealing with potential issues are robust and this means the risks are reduced, but why take a chance. 

 

2. Make your site more inviting

If your Moodle or Totara Learn site is on an older version the site may look outdated. Branding that looked great 2 years ago can be out-of-touch with expectations of your current visitors. Current versions offer more opportunities to make your site look great so that you attract and maintain more engagement than ever before

 

3. Features, features, features!

A popular driver for many clients wishing to upgrade their site are the inevitable new and improved features in the current release. It’s very satisfying to see comments on the roadmap coming to fruition in the software. You may find that you’re spending hours achieving certain results on your site that’s streamlined or improved in the latest release

 

4. No longer supported

There comes a point where Moodle or Totara HQ can no longer support older versions. This means no more security reviews or other bug fixes by the core developers. You can view which versions are supported by Moodle HQ here, and Totara here.

 

Need help with upgrading your Moodle or Totara Learn site? We offer major version upgrade for free if you host with us. Get in touch with our friendly experts on 0330 660 1111 or contact us here.

Need to get ready for GDPR?

Moodle GDPR Compliance


Share this: