HowToMoodle BlogSubscribe to our Blog

Why you must upgrade your Moodle site: GDPR compliance

Upgrade your Moodle site and GDPR compliance

Unless you've hidden away hibernating over the cold Winter months you'll know that GDPR (General Data Protection Regulation) will take effect on 25th May 2018.

And your Moodle site must be compliant.

You may have heard in our recent Podcast that Moodle has released new features to make GDPR compliance possible – but to take advantage of them you’ll need to be using the latest versions of Moodle 3.3 or 3.4 (or 3.5 when it’s released).

 

 


But it's not all about GDPR!

Yes, you read that right. As important as GDPR is, upgrading your Moodle site to a later version has many other benefits that you simply would not want to miss out on!

Why upgrade infographic-1

1. Make your site more secure:

Moodle version upgrades include patches for potential security vulnerabilities. For Moodle, the underlying processes for dealing with potential issues are robust, and this means the risks are reduced.

2. Boost User Experience:

Current Moodle versions offer more opportunities to make your site look fantastic so that you attract and maintain a higher level of engagement than ever before.
 
3. Features, Features, Features!
Aside from the GDPR compliance that we've mentioned, by upgrading your Moodle version you get to experience other new and improved features that can save you hours of workarounds, improve managerial tracking or increase learner engagement.

4. Supported Version:

Some older Moodle versions are simply no longer supported. This means that there are no more security reviews or bug fixes by Moodle's core developers. You can see if your version is supported by Moodle HQ here.

Not sure which version you're on?

Here's how to check...

Log in using an administrator account and follow the below steps to check your current version.

Check if your Moodle site is GDPR Compliant

Moodle site GDPR compliance

 

There's no better time than to upgrade your Moodle site.

Get in touch with our team and let us help you with a painless upgrade.

Moodle GDPR Compliance


Share this: